注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

何静媛 勇往直前

学无止境!

 
 
 

日志

 
 
 
 

转载 注册asp.net 4.0 到iis  

2013-05-18 17:00:29|  分类: .net |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

如果没有按照正常的先装iis后装.net的顺序,可以使用此命令重新注册一下

运行->cmd 

Microsoft Windows [版本 6.1.7601]
版权所有 (c) 2009 Microsoft Corporation。保留所有权利。

C:\Users\Administrator>cd  C:\Windows\Microsoft.NET\Framework\v4.0.30319

C:\Windows\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis.exe -i
开始安装 ASP.NET (4.0.30319)。
................
ASP.NET (4.0.30319)安装完毕。

C:\Windows\Microsoft.NET\Framework\v4.0.30319>

 

无法识别的属性“targetFramework”。请注意属性名称区分大小写。错误解决办法       

 

常见iis错误:

“/CRM”应用程序中的服务器错误。

配置错误

说明:在处理向该请求提供服务所需的配置文件时出错。请检查下面的特定错误详细信息并适当地修改配置文件。

分析器错误消息: 无法识别的属性“targetFramework”。请注意属性名称区分大小写。

源错误: 

行 24:             设置为 true。
行 25:         -->
行 26: 		<compilation debug="true" targetFramework="4.0"/>
行 27: 		<!--
行 28:             通过 <authentication> 节可以配置 ASP.NET 使用的 

源文件: E:\NET\CRM.Web\web.config    行: 26 


版本信息: Microsoft .NET Framework 版本:2.0.50727.4961; ASP.NET 版本:2.0.50727.4955

解决方法:

修改.NET Framework 版本为相应版本即可,我以前用的是2.0换成4.0的时候出现这个错误。

我的win7系统,

1、打开IIs点击IIS根节点

2、看右边的“操作”-》点击“更改.NET Framework 版本”

3、选择相应的版本,我这里应该选择v4.0.30319,点击确定

4、点击IIS的应用程序池

5、在右边“操作”栏里选择“应用程序默认设置...”

6、把“.NET Framework 版本”设置为v4.0,点击“确定”即可。

7、设置需要的版本为允许允许,不然会出现如下错误:

Internet Information Services 7.5

错误摘要

HTTP 错误 404.2 - Not Found

由于 Web 服务器上的“ISAPI 和 CGI 限制”列表设置,无法提供您请求的页面。

设置方法:
(1)、打开ISAPI和CGI限制

(2)、找到你需要但被设为不允许运行的版本,

(3)、把需要运行的版本设置为“允许”,即可

 

  评论这张
 
阅读(473)| 评论(1)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017